Instalar PHP 7.2 en Debian 9

Debian 9 permite instalar mediante apt PHP 7.0, tal y como explico en este enlace.

La próxima versión de Laravel, la 5.6, tiene como requisito disponer de una versión de PHP igual o superior a la 7.1.3, por lo que voy a explicar cómo instalar la última versión estable, la 7.2.

Para ello usaré el DPA (Debian Package Archive) disponible en https://deb.sury.org/ , ya que la versión oficial no se encuentra tan actualizada.

$ sudo apt install apt-transport-https lsb-release ca-certificates
$ sudo wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
$ sudo sh -c 'echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" > /etc/apt/sources.list.d/php.list'
$ sudo apt update

A continuación consulto los paquetes disponibles en este DPA

$ sudo apt-cache search php7.2

Para finalizar instalo los paquetes que necesito, incluyendo el servidor nginx

$ sudo apt install nginx php7.2 php7.2-common php7.2-cli php7.2-fpm php7.2-mysql php7.2-xml php7.2-curl php7.2-mbstring php7.2-zip

Para comprobar que está instalado PHP 7.2 ejecuto

$ php -v
PHP 7.2.1-1+0~20180105151615.16+stretch~1.gbpd3910a (cli) (built: Jan 5 2018 15:16:17) ( NTS )

Más información:

6 thoughts on “Instalar PHP 7.2 en Debian 9

  1. Hola muchas gracias por el tutorial pero se me esta presentando un error al intentar ejecutar el comando PHP 7.2.1-1+0~20180105151615.16+stretch~1.gbpd3910a (cli) (built: Jan 5 2018 15:16:17) ( NTS ) . El error dice: syntax error near unexpected token `(‘ como puedo solucionarlo tienes alguna idea, muchas gracias.

    Saludos

  2. Hola

    “PHP 7.2.1-1+0~20180105151615.16+stretch~1.gbpd3910a (cli) (built: Jan 5 2018 15:16:17) ( NTS )” es la salida del comando
    $ php -v

    por lo que normal que te aparezca un error si tratas de ejecutarlo. Es simplemente la versión de PHP que acabas de instalar.

  3. hola amigo gracias por el aporte pero tengo un problema al agregar el repositorio .
    sudo sh -c ‘echo “deb https://packages.sury.org/php/ $(lsb_release -sc) main” > /etc/apt/sources.list.d/php.list’

    y luego actualizar me sale este error:
    Err:19 https://packages.sury.org/php sid Release
    404 Not Found
    Leyendo lista de paquetes… Hecho
    E: El repositorio «https://packages.sury.org/php sid Release» no tiene un fichero de Publicación.
    N: No se puede actualizar de un repositorio como este de forma segura y por tanto está deshabilitado por omisión.
    N: Vea la página de manual apt-secure(8) para los detalles sobre la creación de repositorios y la configuración de usuarios.

    cual sera el problema saludos

Leave a Reply

Your email address will not be published. Required fields are marked *