Chrome version must be between 70 and 73

Executing the Dusk tests in the WordPress Polyglots Facilitator (Laravel Framework 6.18.31) using a Laravel Homestead virtual machine, I get this error:

 Tests\Browser\DownloadTest::testIosDownload
Facebook\WebDriver\Exception\SessionNotCreatedException: session not created: Chrome version must be between 70 and 73
  (Driver info: chromedriver=2.45.615279 (12b89733300bd268cff3b78fc76cb8f3a7cc44e5),platform=Linux 5.4.0-37-generic x86_64)

These tests need one version of headless Chrome between 70 and 73 and you are running an older or a newer version.

To solve it, you have to install the correct version, using the command:

php artisan dusk:chrome-driver 72

Now the tests works fine.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.